Panel Data Processing is delayed

Incident Report for eDataSource

Resolved

This incident has been resolved.
Posted Nov 07, 2025 - 04:14 EST

Monitoring

One of our upstream providers was having an outage they have resolved. We are seeing recovery on our side and processing is catching up. We ware continuing to monitor.
Posted Nov 07, 2025 - 03:20 EST

Investigating

Panel data processing is currently delayed. We are investigating the issue.
Posted Nov 07, 2025 - 02:21 EST
This incident affected: V4 API, Deliverability - Analytics Tracker, Inbox Tracker, and Competitive Tracker.