Google Postmaster Tools Delayed Data
Incident Report for eDataSource
Resolved
This incident has been resolved.
Posted Nov 15, 2024 - 11:44 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 15, 2024 - 09:16 EST
Update
We are continuing to see delays in the Google Postmaster data. Our team is monitoring and reaching out to Google for updates.
Posted Nov 11, 2024 - 12:30 EST
Identified
Google Postmaster Tools data has not been updated in Inbox Tracker since 2 November 2024. This is an issue at Google and appears to be impacting all Google Postmaster Tools users. Google Postmaster Tools data will backfill as soon as it is available.

We will update the Google Postmaster Tools data in Inbox Tracker once it is available
Posted Nov 07, 2024 - 09:43 EST
This incident affected: Deliverability - Postmaster Tools.